אפל (Apple) מעדכנת את לקוחותיה בתקלה יוצאת דופן, שעשויה לפגוע בפעולתו התקינה של מקלט ה-GSP במכשירי iPhone ישנים ובמקרים מסוימים אף להשבית אותם לחלוטין. התקלה צפויה להחריף באופן משמעותי ב-3 בנובמבר, ועל כן מתבקשים הלקוחות לעדכן את מכשיריהם בגרסה החדשה ביותר של מערכת ההפעלה iOS לפני כן.

יסוד הבעיה הוא באופן שבו מערכת לווייני ה-GPS מעדכנת את המכשיר בתאריך ובשעה המדויקים, לפיהם מחושב גם המיקום. בכל 20 שנים לערך נדרש "אתחול" לנוסחת החישוב, אולם דגמים ישנים יותר עשויים להיכשל בתהליך אתחול זה. התוצאה? לוח השנה של המכשיר עשוי לקפוץ למועד מוקדם ב-20 או אף 40 שנים מהתאריך הנכון.

בכדי להמנע מהתקלה, נדרש כאמור עדכון של מערכת ההפעלה iOS. בשל חומרת הבעיה דאגה אפל להפיץ עדכון עבור גרסאות מיושנות יחסית: iOS 9 ו-iOS 10, עבור מכשירים שלא ניתן להתקין עליהם מערכות הפעלה חדשה יותר. הדגם המוקדם ביותר שזכה לעדכון שכזה הוא iPhone 4s, שהגיע לשוק ב-2011.

באשר למכשירים ישנים יותר, אפל לא מציעה בשלב זה כל פתרון – כנראה שבחברה מצפים כי בעלי iPhone בן שמונה שנים ומעלה יבחרו סוף-סוף לשדרג אותו. מכשירי ה-iPhone הנוכחיים, אגב, משתמשים בחישוב 13 ביט מתקדם, ולכן נדרשים לאתחול לעיתים רחוקות יותר. הם צפויים בסופו של דבר להיתקל בבעיה דומה – אך רק בעוד 157 שנים.